|
Posted by Oli Filth on 11/03/00 11:33
FluffyCat said the following on 01/12/2005 04:48:
> Ladies and gentlemen, I present to you my rendition of the The Chain
> of Responsibility Pattern in PHP 5.
>
> http://www.fluffycat.com/SDCMSv2/PHP-Design-Patterns-Chain-of-Responsibility/
Two recommendations on this one:
1. Alter the description; it's not "moving up a class hierarchy", as
there is no hierarchy (hierarchy implies inheritance tree, which you
don't have).
2. Most of your testXXX.php scripts are very dense and difficult to
read. I'd recommend removing the bizarre tagins() notation, and just
stick with "<html>", etc. as it would be far easier to read than all
these extraneous function calls which just bulk out the script.
In fact, the HTML is irrelevant, so it would make things clearer to do
away with HTML altogether, and use a "text/plain" content-type.
Also, space out the string concatenations, i.e.:
echo 'topic: ' . $bookSubSubTopic->getTopic() . tagins("br");
instead of:
echo 'topic: '.$bookSubSubTopic->getTopic().tagins("br");
Some consistency with single/double-quotes would be helpful as well.
--
Oli
Navigation:
[Reply to this message]
|