|
Posted by Marijn on 09/04/07 10:11
On 4 sep, 10:02, Toby A Inkster <usenet200...@tobyinkster.co.uk>
wrote:
> Marijn wrote:
> > private function __getDatabaseConnection(){
> > if (!$this->__databaseConnection) {
> > $this->__databaseConnection = new DatabaseFactory();
> > };
> > return($this->__databaseConnection);
> > }
> > }
>
> I certainly prefer this.
But because it's faster or..?
>
> > By the way, another small convention question: Should you terminate
> > control structures with a semicolon?
>
> No. In fact, in this particular case, you don't even need the braces.
> Using my own preferred coding style, it would be:
I do prefer the braces. Really makes my code more readable
> private function __getDatabaseConnection ()
> {
> if (!isset($this->__databaseConnection))
> $this->__databaseConnection = new DatabaseFactory();
>
> return $this->__databaseConnection;
> }
>
> By the way, you shouldn't name your functions with a double-underscore.
> Functions that start with a double-underscore are reserved for future use
> as "magic" functions (e.g. __construct, __call, __get, __autoload, etc).
>
I know it is for reserverd magic functions BUT this way i serarate
public (no underscore) from (protected one underscore) from (private
(two underscores)
I really prefer a difference in my code for private and protected
methods.
Plus everybody with a bit of experience knows that ther is __call,
__autoload, __desctruct ...etc.
Navigation:
[Reply to this message]
|